Office Communication Server Mobile “You are currently not using the recommended version of the client”

If you receive the error: “You are currently not using the recommended version of the client” on your OCS mobile client then you are probably running into the Client Version Filter.  To remedy this, you have to change the CPE value in the Client Version Filter to a value greater than the current version of your mobile client on both the Standard server and the Access Edge server. 

1)check the version on the mobile client by going to the options screen (from the client menu) and selecting Help.
2) In the OCS Console for the Standard Server, right-click the pool, select Application Properties -> Client Version Filter.  You will get a screen that looks like the one below:

3) Edit the CPE value to one less then the current version on your device.
4) For the Access Edge Server, use the ClientVersionFilterConfig.exe under Program FilesCommon FilesMicrosoft Office Communications Server 2007 to change the CPE.
5) Restart the RTCSRV on both servers.

 Thanks to this article for the info!